[Résolu] Kwrite et encodage UTF-8

Forum d'aide générale sur Slackware
Vigen
Messages : 57
Inscription : 01 mai 2017, 11:32

[Résolu] Kwrite et encodage UTF-8

Message par Vigen » 11 juin 2017, 16:59

Bonjour à tous.

Je n'arrive pas à trouver le réglage correct pour Kwrite et l'encodage des caractères.
Je me retrouve avec des caractères du genre :

télécharger désiré

Enfin ce genre de trcu quoi !! :)

Quelle paramètres utilisez-vous?

Merci par avance;

Vigen.
Dernière modification par Vigen le 12 juin 2017, 21:26, modifié 1 fois.

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 117
Inscription : 08 janvier 2017, 07:14

Re: Kwrite et encodage UTF-8

Message par Thomas » 11 juin 2017, 17:03

Salut,

Ouvre un terminal et tape "locale". Si tu n'es pas en UTF-8, tu dois éditer (en root) le fichier "/etc/profile.d/lang.sh" puis remplacer la ligne

Code : Tout sélectionner

LANG=en_US
par

Code : Tout sélectionner

LANG=fr_FR.UTF-8
et enfin relancer ta session X.
Thomas Bourdon

Vigen
Messages : 57
Inscription : 01 mai 2017, 11:32

Re: Kwrite et encodage UTF-8

Message par Vigen » 11 juin 2017, 17:11

Salut Thomas,

Le fichier lang.sh est correctement renseigné.

Je pense que cela viens vraiment de la configuration de Kwrite.

Vigen.

paradise
Messages : 16
Inscription : 09 février 2017, 03:47

Re: Kwrite et encodage UTF-8

Message par paradise » 12 juin 2017, 13:26

Bonjour,

Ton KDE est bien en français ?
La langue française bien listée en préférence dans Configuration du système/Localisation ?
OS PC et Portable : Mageia et Slackware 14.1 multilib.

Vigen
Messages : 57
Inscription : 01 mai 2017, 11:32

Re: Kwrite et encodage UTF-8

Message par Vigen » 12 juin 2017, 21:24

Bonsoir Paradise,

Oui oui, je crois avoir trouvé.

Kate, contrairement à Kwrite, encodé encore en ISO.

Après modif des paramètres et vérifications avec la commande :

Code : Tout sélectionner

file
(Merci Thomas ;) )

Tout à l'air d'être correct.

Je passe en résolu ;)

Vigen.

Répondre