[Résolu] Freeze au lancement startx / Ati Rage 128

Forum d'aide générale sur Slackware
Henri IV
Messages : 4
Inscription : 27 juin 2017, 15:27

[Résolu] Freeze au lancement startx / Ati Rage 128

Message par Henri IV » 27 juin 2017, 15:36

Bonjour à tous,

Pour commencer avec LINUX/Slackware et me faire la main sur ce système avant de l'installer sur mes autres plateformes, je l'ai installé sur une machine ancienne mais bien fonctionnelle (fonctionne graphiquement sous Windows XP et sous Puppy Linux/Slacko).

J'ai suivi, sans aucun PB, l'installation décrite dans l'excellent ouvrage de Kiki Novak, mais au lancement de l'interface graphique (startx) c'est le blocage avec clavier et souris apparemment inopérants (cependant, il y a des accès disque). L'écran affiche "Signal entrée hors limites" puis "Mise en veille du moniteur" et s'éteint. Seule solution : l'arrêt hard.

Précisions :

RAM 512 Mo longuement testée sans erreur. Disque 38 Go OK.

Plateforme matérielle HP VECTRA VL420 - P4 - 1,8 GHz - 32bits : http://h10032.www1.hp.com/ctg/Manual/lpv06569.pdf

Lecteur CD présent, pas DVD - pas de boot USB.

Carte graphique : ATI RAGE 128 PRO

Iso installé à partir des 3 premiers CD téléchargés le 25/06/17 (http://mirrors.slackware.com/slackware/slackware-iso/) et vérifiés (MD5). Install conforme aux recommandations de Kiki Novak dans son livre. Création d'un utilisateur non admin en plus du root.

Le mode console fonctionne normalement.

Grand merci à l'avance pour votre aide !

Amicalement
Henri IV
Dernière modification par Henri IV le 29 juin 2017, 09:01, modifié 1 fois.

dodo
Messages : 21
Inscription : 31 janvier 2017, 18:26

Re: Freeze au lancement startx / Ati Rage 128

Message par dodo » 27 juin 2017, 19:00

Houla c'est qu'elle est pas toute jeune cette CG :mrgreen: C'est de l'AGP ou du PCI cette carte ? :mrgreen: Ce genre de carte est supportée jusqu'à une Slack 8.0 ou moins.. Si tu gardes ton P4 -> upgrade de CG.

Vigen
Messages : 57
Inscription : 01 mai 2017, 11:32

Re: Freeze au lancement startx / Ati Rage 128

Message par Vigen » 27 juin 2017, 22:33

Bonsoir et bienvenue.

Vous avez bien téléchargé le cd 32 bits? (on ne sait jamais !! :) )

Effectivement, comme l'indique dodo, la carte graphique commence certainement à être "hors d'âge". En faisant une requète sur un moteur de recherche, de nombreux problèmes de compatibilité ressortent avec cette carte et Linux.

De plus, au vu de la ram du système et de la carte graphique, je pense qu'il n'est pas pensable de faire tourner KDE4 par exemple.
XFCE me parait le plus judicieux, en bureau officiel.

La 14.2 propose bien une version de pilote pour votre carte :
https://slackware.pkgs.org/14.2/slackwa ... 1.txz.html

Attention, le lien ci-après concerne les processeurs supportant les instructions 64 Bits :

https://slackware.pkgs.org/14.2/slackwa ... 1.txz.html

Pour voir si le paquet est installé, pouvez-vous nous donner le retour de la commande :

Code : Tout sélectionner

# slackpkg search xf86-video-r128
Donc, moralité, votre carte est supportée :)

Je vous propose d'attendre encore un peu, d'autres habitués viendrons certainement nous apporter leurs lumières :)

@dodo c'est une AGP 2x/4x ;)

Full AGP 2X/AGP 4X suppo
rt (up to 1GB/s bandwidth)

128bit 2D engine

Floating-point 3D setup engine wi
th complete 3D primitive support

High Quality DVD/MPEG2 playback with iDCT and motion compensation support

DirectX 8 and OpenGL hardware acceleration


Vigen.

Henri IV
Messages : 4
Inscription : 27 juin 2017, 15:27

Re: Freeze au lancement startx / Ati Rage 128

Message par Henri IV » 28 juin 2017, 10:11

Merci beaucoup pour vos informations et conseils. C'est vraiment rassurant de se sentir accompagné. :)

Voici mes réponses :
Vous avez bien téléchargé le cd 32 bits?
oui
De plus, au vu de la ram du système et de la carte graphique, je pense qu'il n'est pas pensable de faire tourner KDE4 par exemple.
XFCE me parait le plus judicieux, en bureau officiel.
oui, c'est ce que j'ai prévu lors de l'install : XCFE en windows manager par défaut
Pour voir si le paquet est installé, pouvez-vous nous donner le retour de la commande :
# slackpkg search xf86-video-r128
Retour :

Code : Tout sélectionner

This appears to be the first time youhave to run slackpkg.
Before you install|upgrade|reinstall anything, you need to uncomment
ONE mirror  in /etc/slackpkg/mirrors and run:
# slackpkg update
C'est ce que j'ai fait en dé-commentant le miroir ftp.fu-berlin.de dans la liste
Il ne marchait pas... j'ai essayé le miroir Suisse avec plus de succès

J'ai relancé : slackpkg update ensuite qui a bien fonctionné.

Ensuite :
Pour voir si le paquet est installé, pouvez-vous nous donner le retour de la commande :
# slackpkg search xf86-video-r128
Retour :

Code : Tout sélectionner

[ installed ] - xcf86-video-r128-6.10.1-i586-1
Cela semble donc OK...

Cependant, startx conduit toujours aux mêmes symptômes :(

Encore merci
Henri IV

Didier Spaier
Messages : 42
Inscription : 29 janvier 2017, 21:07

Re: Freeze au lancement startx / Ati Rage 128

Message par Didier Spaier » 28 juin 2017, 14:12

Essaye ceci, à taper comme root:

Code : Tout sélectionner

cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf
Ensuite, comme simple utilisateur tapes:

Code : Tout sélectionner

startx

Henri IV
Messages : 4
Inscription : 27 juin 2017, 15:27

Re: Freeze au lancement startx / Ati Rage 128

Message par Henri IV » 28 juin 2017, 14:51

:D SUPER !!!

J'affiche enfin le bureau XCFE et je ne suis plus bloqué.

Je vais pouvoir continuer ma découverte ;)

J'ai bien noté que le fichier devait nécessairement s'appeler xorg.conf

Mille mercis pour votre rapidité et votre efficacité

A+ (probablement)
Henri IV

Vigen
Messages : 57
Inscription : 01 mai 2017, 11:32

Re: Freeze au lancement startx / Ati Rage 128

Message par Vigen » 28 juin 2017, 18:13

Bonsoir,

Je note "l'astuce" de Didier que je salue au passage !! :)

Pouvez-vous éditer votre premier message et ajouter [Résolu] dans le titre s'il vous plait?
Cela permet une meilleure lisibilité des éventuels posts en attente de résolution.

Merci :)

Vigen.

dodo
Messages : 21
Inscription : 31 janvier 2017, 18:26

Re: Freeze au lancement startx / Ati Rage 128

Message par dodo » 28 juin 2017, 19:33

Ok mais pas d'accélération en mode fb.. Sinon une bonne carte en agp 4x il y a la Radeon 9250 (avec un port dvi en prime), on en trouve sur la bay. Ben ici j'en utilise une sur un PIII coppermine 1Ghz ;)

Henri IV
Messages : 4
Inscription : 27 juin 2017, 15:27

Re: [Résolu] Freeze au lancement startx / Ati Rage 128

Message par Henri IV » 29 juin 2017, 09:16

OK - J'ai passé le sujet en [Résolu].
C'est une machine de récup qui me sert juste à me familiariser avec LINUX.
Dès que je me sentirai à l'aise avec la Slackware, je l'installerai sur d'autres machines, beaucoup plus actuelles :D
Encore merci
Henri IV

Répondre