14.2 - Configuration du son

Forum d'aide générale sur Slackware
ecforum
Messages : 17
Inscription : 18 août 2017, 10:04

14.2 - Configuration du son

Message par ecforum » 16 septembre 2017, 13:02

Bonjour,

Encore moi... A ma décharge, ça n'est pas plug&play ; c'est balo.

1- Le son fonctionne. Mais je me suis rendu compte sous X dans Kde que la 1ière application qui prend le son empêche les autres d'y avoir accès. Si on ferme l'appli, une autre va prendre le son de manière exclusive. Comment résoudre le problème ?

2- Sur mes Slackware précédentes, alsa servait à la gestion du son. Maintenant c'est pulseaudio, qui, selon l'image de wikipedia (https://fr.wikipedia.org/wiki/PulseAudi ... ram-fr.svg), est un gros bousin entre alsa dans la couche linux et les applications au dessus.
2.a Sur la 14.2, alsamixer a comme device pulseaudio. J'espere que ca ne passe pas d'alsa, à pulseaudio, pour revenir dans alsa puis dans l'appli...
2.b Est-ce une bonne idée de désactiver pulseaudio ou, au pire, de le brancher sur alsa (et pas l'inverse !). Mais que mes applications qui le supportent utilisent directement alsa ? Ceci parce que la 14.2 est bien plus poussive que ma 13.37 et que l'usine à gaz pulseaudio du wiki ne m'enthousiasme pas au 1ier abord...

Merci

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 117
Inscription : 08 janvier 2017, 07:14

Re: 14.2 - Configuration du son

Message par Thomas » 16 septembre 2017, 14:26

Depuis 14.2 alsa est fait pour fonctionner par défaut avec pulseaudio. Si tu veux t'en débarrasser, il faut configurer alsa. Pour cela édites le fichier /etc/asound.conf.

Ceci est ma config de alsa sans pulseaudio, il faudra que tu ajustes les lignes "hw:1,0" et "card 1" suivant ton cas.

Code : Tout sélectionner

pcm.!default { 
    type plug 
    slave.pcm "dmixer" 
} 

pcm.dmixer  {
  type dmix
  ipc_key 1024
  ipc_gid audio
  ipc_perm 0660
  slave {
    pcm "hw:1,0"
    period_time 0
    period_size 1024
    buffer_size 4096
    rate 44100
  }
  bindings {
    0 0
    1 1
  }
}

pcm.dsp0 { 
    type plug 
    slave.pcm "dmixer" 
} 

pcm.default { 
   type plug 
   slave.pcm "dmixer" 
} 

ctl.dmixer {
  type hw
  card 1
}
Mais depuis quelques mois j'ai finalement installé pulseaudio. Comme toi je ne voulais pas voir cette horreur chez moi et finalement il fonctionne très bien sans souci. En fait je préfère même à avant car maintenant je peux régler le volume par appli et non avoir un seul volume pour toutes.
Thomas Bourdon

Seb
Messages : 45
Inscription : 22 février 2017, 19:07

Re: 14.2 - Configuration du son

Message par Seb » 16 septembre 2017, 16:07

À noter que chez moi, qui suis resté sur ALSA, j'ai juste vidé asound.conf, puis fait les réglages avec alsamixer (à enregistrer ensuite via alsactl store). Ça marche aussi sans problème, mais à voir pour les gens qui ont des besoins moins basiques que les miens.

ecforum
Messages : 17
Inscription : 18 août 2017, 10:04

Re: 14.2 - Configuration du son

Message par ecforum » 16 septembre 2017, 17:15

Au final, j'ai commencé par faire exactement comme Seb. Ca marche.

J'ai testé et je me suis rendu compte que mon problème vient du plugin flash : il va directement sur le device sans passer par pulseaudio. Quand il est lancé, rien ne peut utiliser le son. Et quand une appli utilise le son, pulse lui interdit probablement l'accès au device.

Mes besoins sont aussi très limités : regarder des videos avec mplayer en local et en ligne dans firefox. En ligne il y a html5 et flash_player en gros.
J'ai lu aussi que firefox ne supporte plus que pulseaudio depuis la version 52.
Donc, vu mes besoins, je dois garder pulseaudio.

J'ai donc 2 questions liées à pulseaudio :
1- Y a-t-il un moyen que flash-player utilise pulseaudio plutôt que le hardware ?
2- Comment configurer le volume du son : le son sur mplayer est trop fort quand dans firefox il l'est à peine assez, sachant qu'il est à fond dans les 2 applis ? Idem dans flash : c'est faiblard à fond...

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 117
Inscription : 08 janvier 2017, 07:14

Re: 14.2 - Configuration du son

Message par Thomas » 16 septembre 2017, 17:56

ecforum a écrit :
16 septembre 2017, 17:15
J'ai donc 2 questions liées à pulseaudio :
1- Y a-t-il un moyen que flash-player utilise pulseaudio plutôt que le hardware ?
Ce truc est encore utile ? Ça fait un bon moment que je peux lire des vidéos à peu près partout sans flash.
Mais pour répondre à ta question : aucune idée.
ecforum a écrit :
16 septembre 2017, 17:15
2- Comment configurer le volume du son : le son sur mplayer est trop fort quand dans firefox il l'est à peine assez, sachant qu'il est à fond dans les 2 applis ? Idem dans flash : c'est faiblard à fond...
Tu as le volume général que tu peux toujours régler avec alsamixer (75% chez moi). Ensuite tu as un volume par appli, par défaut chaque appli à le volume à 100%. Pour régler le son dans mplayer, tu as les touches "*" et "/" pour respectivement monter et baisser le volume.
Thomas Bourdon

Répondre