(résolu)AbiWord mal installé (ne se lance pas)

Forum d'aide générale sur Slackware
Avatar de l’utilisateur
pixel
Messages : 7
Inscription : 04 février 2018, 17:02

(résolu)AbiWord mal installé (ne se lance pas)

Message par pixel » 04 février 2018, 17:33

Bonjour

Nouvel utilisateur de la dernière Slackware grâce au bouquin "Débuter sous Linux' (de Kiki Novak) , j'essaie de suivre au mieux
les explications et tout va très bien sauf pour l'installation de AbiWord.
J'ai téléchargé sur pkgs.org : Emacs, Gthumb, Leafpad et Abiword. L'installation c'est bien déroulée sauf pour Abiword que
je n'arrive pas à lancer bien qu'il soit présent dans le menu applications/bureautique.
Voici en copie les messages du terminal :

Code : Tout sélectionner

root@slackbox:/home/dvador/pkg# installpkg abiword-3.0.1-x86_64-1rl.txz
Verifying package abiword-3.0.1-x86_64-1rl.txz.
Installing package abiword-3.0.1-x86_64-1rl.txz:
PACKAGE DESCRIPTION:
# abiword (word processing for everyone)
# 
# AbiWord is a lean and fast full-featured word processor. It can import
# many formats including Word97/2000 and RTF, Palm, Psion, DocBook and
# XHTML documents, and can export to RTF, Palm, Psion, XHTML, Text,
# and LaTeX formats. Linux Journal calls it "an elegant, open source
# word processor that delivers the Word functionality most people use."
# 
Package abiword-3.0.1-x86_64-1rl.txz installed.
Quand je lui demande si AbiWord est installé, il me dit, pas de fichier ne de répertoire:

Code : Tout sélectionner

root@slackbox:/home/dvador/pkg# ls/var/log/packages/abiword*
-su: ls/var/log/packages/abiword*: No such file or directory
Suis un peu perdu, si quelqu'un à une idée...
Dernière modification par pixel le 05 février 2018, 18:07, modifié 2 fois.
sierra; lubuntu; slackware et... un cochon d'inde :mrgreen:

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 192
Inscription : 08 janvier 2017, 07:14

Re: AbiWord mal installé (ne se lance pas)

Message par Thomas » 04 février 2018, 18:14

pixel a écrit :
04 février 2018, 17:33
Bonjour

Nouvel utilisateur de la dernière Slackware grâce au bouquin "Débuter sous Linux' (de Kiki Novak) , j'essaie de suivre au mieux
les explications et tout va très bien sauf pour l'installation de AbiWord.
Bonjour et bienvenue.
pixel a écrit :
04 février 2018, 17:33
J'ai téléchargé sur pkgs.org : Emacs, Gthumb, Leafpad et Abiword. L'installation c'est bien déroulée sauf pour Abiword que
je n'arrive pas à lancer bien qu'il soit présent dans le menu applications/bureautique.
Voici en copie les messages du terminal :

Code : Tout sélectionner

root@slackbox:/home/dvador/pkg# installpkg abiword-3.0.1-x86_64-1rl.txz
Verifying package abiword-3.0.1-x86_64-1rl.txz.
Installing package abiword-3.0.1-x86_64-1rl.txz:
PACKAGE DESCRIPTION:
# abiword (word processing for everyone)
# 
# AbiWord is a lean and fast full-featured word processor. It can import
# many formats including Word97/2000 and RTF, Palm, Psion, DocBook and
# XHTML documents, and can export to RTF, Palm, Psion, XHTML, Text,
# and LaTeX formats. Linux Journal calls it "an elegant, open source
# word processor that delivers the Word functionality most people use."
# 
Package abiword-3.0.1-x86_64-1rl.txz installed.
En effet abiword est bien installé.
pixel a écrit :
04 février 2018, 17:33
Quand je lui demande si AbiWord est installé, il me dit, pas de fichier ne de répertoire:

Code : Tout sélectionner

root@slackbox:/home/dvador/pkg# ls/var/log/packages/abiword*
-su: ls/var/log/packages/abiword*: No such file or directory
Suis un peu perdu, si quelqu'un à une idée...
Tout d'abord il manque un espace dans ta dernière commande entre "ls" et "/var/log/packages/abiword*" d'où ce message d'erreur.
Sinon as-tu essayé d'exécuter abiword depuis un terminal ? Il y a de grandes chances pour qu'il manque des dépendances. En effet, Slackware est la seule distribution gnu/linux à ne pas gérer les dépendances. Dans ce cas, lorsque tu installes abiword, il n'installe que abiword sans installer les dépendances nécessaires.
Je te conseille de regarder du côté de slackbuilds.org qui donne les dépendances nécessaires pour installer un logiciel comme abiword.

Bon courage ! :)
Thomas Bourdon

Avatar de l’utilisateur
pixel
Messages : 7
Inscription : 04 février 2018, 17:02

Re: AbiWord mal installé (ne se lance pas)

Message par pixel » 04 février 2018, 20:00

Bonjour Thomas
Merci de m'avoir répondu, dans la console, abiword ne se lance pas. Trouvé sur slackbuilds.org mais c'est des tar.gz qui je crois est un fichier compressé.
Bien qu'il y ai un chapitre sur les divers modes de compressions, je n'arrive pas à passer les tar.gz en tar.txz.
Désolé pour mes erreurs de débutant...
sierra; lubuntu; slackware et... un cochon d'inde :mrgreen:

Didier Spaier
Messages : 63
Inscription : 29 janvier 2017, 21:07

Re: AbiWord mal installé (ne se lance pas)

Message par Didier Spaier » 04 février 2018, 20:15

Bonjour pixel.

En règle générale ne se fier à pkgs.org, et utiliser seulement des dépôts qui ne contiennent que des paquets faits pour s'installer sur Slackware.

abiword-3.0.1-x86_64-1rl.txz est un paquet pour Salix maintenu par Richard Lapointe. Une chance, tu aurais pu plus mal tomber. Mais le répertoire Salix est conçu pour être utilisé avec la gestion des dépendances par slap-get, non inclus dans Slackware, et les dépendances y sont calculées pour Salix, donc peut-être pas complètes.

Bon, comme Slint inclut slapt-get , je viens de vérifier que tu as au moins besoin de wv, qu tu peux trouver ici:
http://slackware.uk/salix/x86_64/14.2/salix/l/
Le paquet est: http://slackware.uk/salix/x86_64/14.2/s ... 64-2rl.txz
Je ne peux pas garantir à 100% que ça suffit car Slint comporte des paquets non inclus dans Slackware mais essaie déjà ça.

D'autre part, emacs est inclus dans Slackware, pourquui aller le chercher ailleurs?

@Thomas: le site est bien plus réactif, c'est super! Qu'as-tu changé?

Didier Spaier
Messages : 63
Inscription : 29 janvier 2017, 21:07

Re: AbiWord mal installé (ne se lance pas)

Message par Didier Spaier » 04 février 2018, 20:16

pixel a écrit :
04 février 2018, 20:00
Bonjour Thomas
Merci de m'avoir répondu, dans la console, abiword ne se lance pas. Trouvé sur slackbuilds.org mais c'est des tar.gz qui je crois est un fichier compressé.
Bien qu'il y ai un chapitre sur les divers modes de compressions, je n'arrive pas à passer les tar.gz en tar.txz.
Désolé pour mes erreurs de débutant...
Lecture nécessaire:
https://slackbuilds.org/howto/

Avatar de l’utilisateur
pixel
Messages : 7
Inscription : 04 février 2018, 17:02

Re: AbiWord mal installé (ne se lance pas)

Message par pixel » 04 février 2018, 21:56

Bonjour Didier Spaier

Toujours le nez dans le bouquin de Kiki Novak, je viens de voir que les tar.gz nécessitaient une compilation. Donc je vais suivre les tutos du livre, ça devrait le faire.

Sinon, je suis paumé avec wv... tu peux m'en dire un peu plus?

En fait, dans le bouquin, il est mentionné de ne pas installer Emacs car cela fait partie d'un tuto plus en avant du livre qui démontre comment installer Emacs (à titre d’exemple) d'après un téléchargement sur http://mirrors.slackware.com/slackware/.

Ce bouquin est très complet pour un neuneu comme moi, mais il faut bien dire que c'est pas simple de trouver le bon paquet à cette adresse.
Donc, je me suis rabattu sur pkgs.org ...

Merci pour le lien https://slackbuilds.org/howto/, j'ai commencé à le lire avec google translate.

Bon, je vais y arriver, avec un peu de temps... et grâce à votre aide!
sierra; lubuntu; slackware et... un cochon d'inde :mrgreen:

Didier Spaier
Messages : 63
Inscription : 29 janvier 2017, 21:07

Re: AbiWord mal installé (ne se lance pas)

Message par Didier Spaier » 04 février 2018, 22:13

pixel a écrit :
04 février 2018, 21:56
Sinon, je suis paumé avec wv... tu peux m'en dire un peu plus?
Essaie ceci (commandes à taper dans un terminal):

Code : Tout sélectionner

wget http://slackware.uk/salix/x86_64/14.2/salix/l/wv-1.2.4-x86_64-2rl.txz
su # il faut être root pour installer
installpkg wv-1.2.4-x86_64-2rl.txz
Ensuite, abiword étant déjà installé, taper "abiword &" (sans les guillemets) devrait le lancer.

Dans ce cas tu n'auras pas besoin de compiler avec un SlackBuild cette fois-ci.

PS AbiWord est bien installé, mais il lui manque une dépendance (un autre logiciel dont il a besoin pour fonctionner), wv.

C'est aussi indiqué sur cette page:
https://slackbuilds.org/repository/14.2/office/abiword/
de la façon suivante:
This requires: wv

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 192
Inscription : 08 janvier 2017, 07:14

Re: AbiWord mal installé (ne se lance pas)

Message par Thomas » 05 février 2018, 01:14

Didier Spaier a écrit :
04 février 2018, 20:15
@Thomas: le site est bien plus réactif, c'est super! Qu'as-tu changé?
Salut Didier, je suis passé de l'auto-hébergement derrière une simple connexion ADSL avec un débit très moyen à un serveur dédié en datacenter. :)
Thomas Bourdon

Avatar de l’utilisateur
pixel
Messages : 7
Inscription : 04 février 2018, 17:02

Re: AbiWord mal installé (ne se lance pas)

Message par pixel » 05 février 2018, 10:43

Bonjour

Bon, ça ne fonctionne pas, abiword ne se lance toujours pas malgré tes conseils.
Du coup, j'ai compilé le programme :
1) Télécharger sur Salckbuilds l'archive contenant les scripts
2)Télécharger l'archive contenant le code source
3)Décompresser l'archive des scripts
4)Déplacé le code source dans le nouveau répertoire
5)Vérifié avec tree abiword
6)Placé dans le répertoire
7)Puis ./abiword.SlackBuild pour la construction du paquet

Et là, messages d'erreurs:

Code : Tout sélectionner

abiword-3.0.2/libgcrypt.m4
abiword-3.0.2/ltsugar.m4
abiword-3.0.2/m4_ax_boost_base.m4
abiword-3.0.2/COPYRIGHT.TXT
abiword-3.0.2/configure.ac
abiword-3.0.2/BUILD.TXT
abiword-3.0.2/py-compile
abiword-3.0.2/abiword.desktop
abiword-3.0.2/plugin-list.m4
abiword-3.0.2/test-driver
abiword-3.0.2/INSTALL
abiword-3.0.2/plugin-makefiles.m4
tar: /home/dvador/pkg/abiword/abiword-docs-3.0.2.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

Toujours pas de fichier ou dossier. Pourtant j'ai respecté la structure du bouquin.
J'ai l'impression que je suis pas loin de la solution, mais j'avoue que je galère. :roll:

Merci de votre aide!
sierra; lubuntu; slackware et... un cochon d'inde :mrgreen:

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 192
Inscription : 08 janvier 2017, 07:14

Re: AbiWord mal installé (ne se lance pas)

Message par Thomas » 05 février 2018, 10:50

Salut pixel,

Tu dois également télécharger le fichier abiword-docs-3.0.2.tar.gz dans "/home/dvador/pkg/abiword/" comme indiqué sur la page du slackbuild.

Bon courage ! :)
Thomas Bourdon

Répondre