[Résolu] Problème d'adresse IP sur le réseau local

Forum d'aide générale sur Slackware
hapalemur
Messages : 12
Inscription : 30 janvier 2017, 20:41

[Résolu] Problème d'adresse IP sur le réseau local

Message par hapalemur » 07 avril 2018, 18:52

Bjr,
Sur un réseau local j'ai :
  • un routeur Zyxel sur lequel je n'ai pas la main
  • un équipement Linux (serveur web)
Le routeur Zyxel est paramétré par une tierce personne pour renvoyer tout trafic sur la plage de ports 50000-50100 vers l'adresse 192.168.1.254
J'ai configuré l'équipement en adresse statique 192.168.1.254
L'accès externe vers le serveur ne se fait pas.

Après avoir connecté un PC portable et effectué un scan du réseau local j'obtiens :
  • 192.168.1.1 : routeur Zyxel
  • 192.168.1.2 : PC portable
  • 192.168.1.3 : serveur Linux
Donc l'adresse IP 192.168.1.254 n'existe pas sur le réseau local.
Je me connecte sur le système Linux en SSH en utilisant l'adresse 192.168.1.3, et sur le sytème la commande ifconfig me renvoie l'adresse 192.168.1.254 pour eth0.
Je ne comprends pas ou se situe le problème.
Dernière modification par hapalemur le 09 avril 2018, 20:23, modifié 1 fois.

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 222
Inscription : 08 janvier 2017, 07:14

Re: Problème d'adresse IP sur le réseau local

Message par Thomas » 09 avril 2018, 10:50

Salut,
Tu peux donner le résultat complet de "ip addr" quand tu es sur ton serveur linux stp ?
Thomas Bourdon

hapalemur
Messages : 12
Inscription : 30 janvier 2017, 20:41

Re: Problème d'adresse IP sur le réseau local

Message par hapalemur » 09 avril 2018, 12:46

Thomas a écrit :Tu peux donner le résultat complet de "ip addr" quand tu es sur ton serveur linux stp ?
Oui, .... dans la semaine :D
Le serveur est situé à 60 kms de mon domicile et je ne m'y rends pas tous les jours.

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 222
Inscription : 08 janvier 2017, 07:14

Re: Problème d'adresse IP sur le réseau local

Message par Thomas » 09 avril 2018, 12:56

OK. Ton serveur web n'est donc pas accessible depuis l'extérieur ? Sinon tu aurais pu te connecter à ton serveur via ssh.
Thomas Bourdon

hapalemur
Messages : 12
Inscription : 30 janvier 2017, 20:41

Re: Problème d'adresse IP sur le réseau local

Message par hapalemur » 09 avril 2018, 13:13

Le but est bien qu'il soit accessible depuis l'extérieur, mais apparement la config actuelle ne le permet pas.
J'ai bien une connexion SSH (port 50022 vu les contraintes mises sur l'utilisation du routeur) d'ouverte sur le serveur.
Et j'ai bien la connexion SSH opérationnelle à partir du réseau local en utilisant l'adresse 192.168.1.3 alors que le serveur est sur l'adresse 192.168.1.254
Mais comme je l'indique dans le 1er post, tout traffic sur les ports 50000 ....50100 est renvoyé sur 192.168.1.254, le routeur ne voit pas cette adresse sur le réseau local alors que le serveur est bien configuré en statique sur cette IP.

Pour résumer :

IP externe:50022 --> Routeur ---> 192.168.1.254:50022 --- réseau local --- 192.168.1.3 <--- serveur Linux : IP statique 192.168.1.254

Le routeur renvoie le traffic vers une IP (192.168.1.254) qui n'existe pas sur le réseau local

hapalemur
Messages : 12
Inscription : 30 janvier 2017, 20:41

Re: Problème d'adresse IP sur le réseau local

Message par hapalemur » 09 avril 2018, 20:22

Le problème est résolu : après contact avec l'entreprise propriétaire et gestionnaire du routeur, un mauvais paramétrage sur les ports avait été effectué, un envoi de mail ce matin, décrivant (voir le 1er post) les problèmes rencontrés a permis a une personne chargée de l'opérationnel de remettre tout en ordre.
Mais je me pose quand même une question : comment se fait-il qu'ayant attribué une IP statique à mon équipement (192.168.1.254), un scan réseau me donne une adresse 192.168.1.3 qui est valide puisque je me connecte à l'équipement en SSH. On dirait que cette adresse est attribuée par le DHCP du routeur, mais il n'a pas du recevoir de demande puisque c'est une IP statique?
@Thomas : comment (avec quel outil) tu vérifies l'ouverture des ports?

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 222
Inscription : 08 janvier 2017, 07:14

Re: Problème d'adresse IP sur le réseau local

Message par Thomas » 10 avril 2018, 06:32

hapalemur a écrit :
09 avril 2018, 20:22
@Thomas : comment (avec quel outil) tu vérifies l'ouverture des ports?
Avec nmap :

Code : Tout sélectionner

# nmap -p 443 -sT -sU hostname
scanne le port 443 en tcp et udp de la machine nommée hostname.
Thomas Bourdon

hapalemur
Messages : 12
Inscription : 30 janvier 2017, 20:41

Re: [Résolu] Problème d'adresse IP sur le réseau local

Message par hapalemur » 29 avril 2018, 13:57

Bjr,
Bon ce n'est pas entièrement résolu : le défaut se situe sur l'attribution de 2 adresses IP à l'équipement.
Ce qui crée le bazar, c'est un module qui est fournit avec Gnome (NetworkManager) qui quelque soit sa configuration utilise le DHCP pour obtenir une adresse IP alors que dans la conf réseau, j'ai mis l'équipement en IP statique.
Ci-dessous le résultat de la commande ip addr

Code : Tout sélectionner

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 7a:53:21:3f:24:cb brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.254/24 brd 192.168.1.255 scope global eth0
    inet 192.168.1.156/24 brd 192.168.1.255 scope global secondary eth0
    inet6 fe80::7853:21ff:fe3f:24cb/64 scope link
       valid_lft forever preferred_lft forever

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 222
Inscription : 08 janvier 2017, 07:14

Re: [Résolu] Problème d'adresse IP sur le réseau local

Message par Thomas » 29 avril 2018, 14:03

Salut,

Je te conseille de ne pas utiliser networkmanager, ceci évitera tout souci. Perso je n'utilise cette appli que sur des PC portables qui se déplacent. Mes PC fixe utilise rc.inet1 pour gérer le réseau.
Thomas Bourdon

hapalemur
Messages : 12
Inscription : 30 janvier 2017, 20:41

Re: [Résolu] Problème d'adresse IP sur le réseau local

Message par hapalemur » 29 avril 2018, 15:20

Merci,
Bon ce n'était pas uniquement NetworkManager : je l'ai supprimé.
Je supprime également l'adresse obtenue par DHCP :

Code : Tout sélectionner

ip addr del 192.168.1.3/24 dev eth0
C'est OK, je n'ai plus qu'une seule adresse; mais au reboot, je me retrouves avec les 2 adresses.

Répondre