Page 1 sur 1

Slackware-current: 15.0 est en route

Publié : 17 novembre 2017, 08:37
par Thomas
Bonjour,

Une grosse mise à jour de slackware-current a eu lieu cette nuit qui tout d'abord annonce, sans grande surprise, le numéro de la prochaine version : 15.0
a/etc-15.0-x86_64-1.txz: Upgraded.
a/pkgtools-15.0-noarch-1.txz: Upgraded.
Le nouveau kernel LTS a également fait son entrée :
a/kernel-generic-4.14.0-x86_64-1.txz: Upgraded.
a/kernel-huge-4.14.0-x86_64-1.txz: Upgraded.
a/kernel-modules-4.14.0-x86_64-1.txz: Upgraded.
d/kernel-headers-4.14.0-x86-1.txz: Upgraded.
k/kernel-source-4.14.0-noarch-1.txz: Upgraded.
imapd et sendmail s'en vont pour laisser la place au célèbre couple postfix et dovecot :
n/imapd-2.21-x86_64-1.txz: Removed.
n/sendmail-8.15.2-x86_64-2.txz: Removed.
Moved to /extra.
n/sendmail-cf-8.15.2-noarch-2.txz: Removed.
Moved to /extra.
n/dovecot-2.2.33.2-x86_64-1.txz: Added.
This will be the new IMAP/POP3 server in the next Slackware release.
Thanks to Alan Hicks, Mario Preksavec, and /dev/rob0 for assistance.
n/postfix-3.2.4-x86_64-1.txz: Added.
This will be the default MTA in the next Slackware release. Thanks to
Alan Hicks, Mario Preksavec, and /dev/rob0 for assistance.
Le démarrage du réseau est maintenant fait par "ip" au lieu de "ifconfig" et "route" :
n/network-scripts-15.0-noarch-1.txz: Upgraded.
Switch to using ip instead of ifconfig and route.
Supports create/destroy of virtual tun/tap interfaces and adding
them to bridges.
Supports additional IP addresses added to interfaces in a way
that's compatible with net-tools.
Thanks to Robby Workman.
La nouvelle monture très médiatisé de firefox est également présente :
xap/mozilla-firefox-57.0-x86_64-1.txz: Upgraded.
tetex a été remplacé par texlive depuis quelques semaines déjà.
Seuls php-7.x et KDE5 n'ont pas encore fait leur entrée (même s'il est toujours possible d'installer les paquets d'alienbob), peut-être dans les semaines à venir.

En tout cas il y a beaucoup de nouveautés par rapport à la version 14.2. Slackware 15.0 sera, comme à chaque fois, un grand cru que nous attendons impatiemment. :)

Re: Slackware-current: 15.0 est en route

Publié : 18 novembre 2017, 12:21
par dodo
Ah ah ! Adieu le vénérable Sendmail :/ Va falloir que je passe à Postfix.. Et ce Ip c'est quoi au juste, un binaire ? Sa syntaxe d'utilisation est comme pour ifconfig ? Ouais vivement la 15.0 8-)

Re: Slackware-current: 15.0 est en route

Publié : 18 novembre 2017, 14:38
par Thomas
"ip" (iproute2) n'a pas du tout la même syntaxe que "ifconfig" (net-tools).
net-tools étant obsolète, il est nécessaire de passer à iproute2.

Re: Slackware-current: 15.0 est en route

Publié : 28 novembre 2017, 21:07
par Incognito
Aaaahhhhhh, hmmmm, c'est bon ça... Punaise, qu'est ce qu j'aime quand y annoncent une nouvelle version, on en sentirait presque une odeur de matin de Noël, combiné à de l'espoir !

Je pige pas que Slackware passe pas officiellement à PaleMoon pourtant, c'est le navigateur qui se rapproche le plus de la philosophie de cette distribution... AlienBob en a pourtant fait la promo sur son blog, c'est même comme ça que je l'ai découvert.

Et ce grand cru, je compte bien m'en griser jusqu'au coma éthylique, et j'en lâcherai pas une goutte ! :twisted:

Re: Slackware-current: 15.0 est en route

Publié : 29 novembre 2017, 19:13
par Seb
Je pige pas que Slackware passe pas officiellement à PaleMoon pourtant, c'est le navigateur qui se rapproche le plus de la philosophie de cette distribution...
À mon avis tant qu'ils n'auront pas clarifier l'usage qu'on peut faire de leur marque, il ne faut pas y compter. Voir également comment ça tient la route face à Quantum. C'est tout le problème des navigateurs dits modernes, il faut des équipes conséquentes et constantes pour les maintenir à niveau (même si toujours et pour toujours lynx les poutre tous :P ).

Re: Slackware-current: 15.0 est en route

Publié : 29 novembre 2017, 19:17
par Thomas
J'ai oublié de préciser l'arrivée de python3 également.
php-7.1 a fait son entrée dans testing cette semaine.

Re: Slackware-current: 15.0 est en route

Publié : 29 novembre 2017, 20:58
par Incognito
Hmmmm, j'approuverai totalement que quand la dernière version de Lua sera là, et pas celle agée de 7 ans... :P
Ça avait causé beaucoup de soucis à des gars qui voulaient utiliser AwesomeWM... Dont moi évidemment.

Pourquoi j'ai l'impression que Python c'est le langage des jeunes ?