Erreur d'installation pour la langue

Forum d'aide générale sur Slackware
Mia
Messages : 7
Inscription : 03 décembre 2017, 18:19

Erreur d'installation pour la langue

Message par Mia » 03 décembre 2017, 18:57

Bonjour,

J'ai fait une erreur au cours de l'installation, je ne trouvais pas une disposition de clavier qui convenait alors j'ai laissé par défaut en Anglais, pensant corriger cela par la suite, seulement je n'y arrive pas :roll:

L'environnement est XFCE et je passe ma session en français avec la commande LANG=fr_FR.utf8 au démarrage, mais ça s'arrête là.
Je ne sais pas comment faire pour que tout le système soit en français.

J'ai modifié le fichier /etc/profile.d/lang.sh (export LANG=fr_FR) mais ça ne fonctionne pas, le clavier est toujours en querty dans la console.[/b]

Image

J'ai débuté sur Linux il y a quelques mois avec Mint, merci de simplifier au maximum les explications :oops:
Dernière modification par Mia le 14 décembre 2017, 17:40, modifié 1 fois.

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 124
Inscription : 08 janvier 2017, 07:14

Re: Erreur d'installation pour la langue

Message par Thomas » 03 décembre 2017, 19:18

Bonjour Mia,

Toutes les commandes suivantes sont à faire en root.

Sous une console tty, édites le fichier rc.keymap :

Code : Tout sélectionner

nano /etc/rc.d/rc.keymap
Puis assure-toi d'avoir la ligne :
/usr/bin/loadkeys fr.map
Pour une session sous X, tu dois copier le fichier "/usr/share/X11/xorg.conf.d/90-keyboard-layout.conf" au bon endroit :

Code : Tout sélectionner

cp /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf /etc/X11/xorg.conf.d
Ensuite édites ce fichier copié à l'aide de nano :

Code : Tout sélectionner

nano /etc/X11/xorg.conf.d/90-keyboard-layout.conf
Et remplace la ligne :
Option "XkbLayout" "us"
par :
Option "XkbLayout" "fr"
Au prochain redémarrage, tout sera en français. :)
Thomas Bourdon

Mia
Messages : 7
Inscription : 03 décembre 2017, 18:19

Re: Erreur d'installation pour la langue

Message par Mia » 04 décembre 2017, 14:53

Bonjour Thomas et merci pour la rapidité de ta réponse :)

Malheureusement je coince dès la première ligne :?
Nano a crée un nouveau fichier quand j'ai voulu éditer, alors je suis allée voir depuis le gestionnaire de fichiers si rc.keymap existait bien, et non il n'y est pas.

Il y avait un fichier nommé rc.keymap.swp :

Image

J'ai voulu l'éditer avec nano mais il crée un nouveau fichier portant ce nom au lieu d'éditer le fichier :evil:
Je suis allée vérifier par le gestionnaire de fichier, il a disparu :o

Image

Je connais plutôt vim que nano, mais je n'ai rien enregistré, seulement regardé, à moins que le simple fait de fermer nano enregistre les modifs (je n'en ai d'ailleurs pas fait) :x

J'ai tout de même copié le fichier xorg.conf.d dans etc et modifié la ligne de l'option XkbLayout de "us" à "fr" mais du coup c'est toujours en anglais et clavier querty.
N'ayant pas trouvé le fichier rc.keymap, je n'ai pas pu vérifier vérifier si la ligne "loadkeys fr.map" y est.

Je ferais peut-être mieux de réinstaller puisque pour ce fichier rc.keymap.swp qui a disparu ? (c'est une machine virtuelle, ça s'installe plus rapidement).

Edit : par contre ma session est en français sans que j'ai à rajouter la ligne LANG=fr_FR.utf8 avant de la démarrer, c'est déjà ça ;)
Dernière modification par Mia le 04 décembre 2017, 15:05, modifié 1 fois.

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 124
Inscription : 08 janvier 2017, 07:14

Re: Erreur d'installation pour la langue

Message par Thomas » 04 décembre 2017, 15:00

Salut,

As-tu fait une installation complète (full install) ? Quelle version de slackware ? 32 ou 64 bits ?

Parfait, moi aussi je préfère vim. :)

ce fichier ".swp" apparaît lors de l'édition du fichier correspondant, c'est tout à fait normal qu'il soit supprimé après édition.

Tente une réinstallation car ce n'est pas normal de ne pas avoir /etc/rc.d/rc.keymap
Thomas Bourdon

Mia
Messages : 7
Inscription : 03 décembre 2017, 18:19

Re: Erreur d'installation pour la langue

Message par Mia » 04 décembre 2017, 15:20

Re,

C'est la version 14.2 en 64 bits, c'est bien une installation complète, enfin il me semble, j'ai vérifié aussi le md5.

Je vais donc réinstaller. Pas facile de débuter :D

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 124
Inscription : 08 janvier 2017, 07:14

Re: Erreur d'installation pour la langue

Message par Thomas » 04 décembre 2017, 15:35

N'hésite pas à passer sur le canal IRC au besoin, même s'il est un peu désert. En tout cas j'y suis en journée, jamais en soirée. :)

Bon courage !
Thomas Bourdon

Mia
Messages : 7
Inscription : 03 décembre 2017, 18:19

Re: Erreur d'installation pour la langue

Message par Mia » 04 décembre 2017, 16:01

OK, merci pour ton accueil ;)

Mia
Messages : 7
Inscription : 03 décembre 2017, 18:19

Re: Erreur d'installation pour la langue

Message par Mia » 08 décembre 2017, 17:47

Salut,

Je reviens sur le forum (pas l'habitude des canaux IRC, j'irai par la suite ;) )
Thomas a écrit :
04 décembre 2017, 15:00
Tente une réinstallation car ce n'est pas normal de ne pas avoir /etc/rc.d/rc.keymap
J'ai lu sur la doc officielle que ce fichier n'existe pas lorsqu'on laisse la langue par défaut.
J'évite habituellement les doc en anglais car je dois passer par un traducteur.

"Veuillez noter que si vous décidez de ne pas changer la disposition par défaut (US) pendant le processus d'installation, le fichier /etc/rc. d/rc. keymap ne sera pas créé. Si, à un stade ultérieur, vous avez besoin de le modifier, vous devrez créer ce fichier, copier le code ci-dessus et choisir l'une des cartes-clés disponibles dans le répertoire /usr/share/kdb/keymaps/."
https://docs.slackware.com/howtos:windo ... ard_layout

J'avais déjà réinstallé, tant pis :D .
Pour cette 2ème install le clavier est bien en azerty dans la console, mais c'est l'interface graphique et l'émulateur de terminal qui sont maintenant en qwerty :mrgreen:
L'environnement XFCE est bien en français, mais pas le clavier !
Je contourne le problème en lançant setxkbmap fr mais je dois recommencer à chaque démarrage.

Comment faire ? sans réinstaller ;)

Merci pour ta réponse.

Avatar de l’utilisateur
Thomas
Administrateur
Messages : 124
Inscription : 08 janvier 2017, 07:14

Re: Erreur d'installation pour la langue

Message par Thomas » 08 décembre 2017, 17:58

Salut,
Mia a écrit :
08 décembre 2017, 17:47
Thomas a écrit :
04 décembre 2017, 15:00
Tente une réinstallation car ce n'est pas normal de ne pas avoir /etc/rc.d/rc.keymap
J'ai lu sur la doc officielle que ce fichier n'existe pas lorsqu'on laisse la langue par défaut.
J'évite habituellement les doc en anglais car je dois passer par un traducteur.
Bon à savoir, je ne savais pas.
Mia a écrit :
08 décembre 2017, 17:47
Pour cette 2ème install le clavier est bien en azerty dans la console, mais c'est l'interface graphique et l'émulateur de terminal qui sont maintenant en qwerty :mrgreen:
L'environnement XFCE est bien en français, mais pas le clavier !
Je contourne le problème en lançant setxkbmap fr mais je dois recommencer à chaque démarrage.

Comment faire ? sans réinstaller ;)
Comme je l'ai indiqué plus haut :
Pour une session sous X, tu dois copier le fichier "/usr/share/X11/xorg.conf.d/90-keyboard-layout.conf" au bon endroit :

Code : Tout sélectionner

cp /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf /etc/X11/xorg.conf.d
Ensuite édites ce fichier copié à l'aide de vim :

Code : Tout sélectionner

vim /etc/X11/xorg.conf.d/90-keyboard-layout.conf
Et remplace la ligne :
Option "XkbLayout" "us"
par :
Option "XkbLayout" "fr"
Il n'y a rien d'autre à faire normalement.
Thomas Bourdon

Mia
Messages : 7
Inscription : 03 décembre 2017, 18:19

Re: Erreur d'installation pour la langue

Message par Mia » 08 décembre 2017, 18:26

Suis-je bête, je pensais que toutes ces lignes servaient à changer le clavier pour la console, en oubliant que "sous X" veut dire dans l'environnement :oops: Pas encore bien familiarisée avec tout ça...

C'est tout bon cette fois, merci bcp ;)

Répondre